Problem building with Xcode11 beta

Problem building with Xcode11 beta

holonicsholonics Member Posts: 12

hi,


While building with the last Xcode beta (needed to deploy on iOS13.2 released yesterday) the compilation fails with the following message :

Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.1 compiler: /Users/xxx/Documents/Dev/Holon/Bose/Frameworks/iOS/BoseWearable.framework/Modules/BoseWearable.swiftmodule/arm64-apple-ios.swiftmodule

Is someone facing the same issue ? do we need an update of the SDK in order to fix this ?

Tegards




Comments

  • holonicsholonics Member Posts: 12
    well, apple somehow made it possible to release to ios13.2 with xcode 11 (non beta), but i guess the problem will appear again when apple releases Xcode 11.2. As such the problem is less urgent but will become blocking at some point again.
  • holonicsholonics Member Posts: 12
    update: Apple pushed Xcode 11.2 out. it means projects cannot be built at all.

    Could someone have a look ?
  • edited 11/04/2019 - 17:00
    Nadine@Bose[email protected] Member Posts: 111
    Hi @holonics ,

    Thanks for reporting this! I reported it to engineering. I'll update this thread. I'll also update my stuff to see if I can reproduce.

    Edit: I can reproduce. I'm on it for a fix. Thanks for being patient.

    Thanks!
    @[email protected]

  • edited 11/04/2019 - 20:00
    Nadine@Bose[email protected] Member Posts: 111

    Hi @holonics,


    We are pushing an updated binary for this fix. I'll update this thread when it is available on the downloads section!


    Thanks so much,

    @[email protected] 


  • holonicsholonics Member Posts: 12
    awesome ! thanks :)
  • innospiringinnospiring Member Posts: 1
    Same problem and error message with the Swift 5.1.2 compiler
  • holonicsholonics Member Posts: 12
    the new SDK has been released now ! dark mode and xcode 11.2 support !
Sign In or Register to comment.