Bose Device Initial detection is very slow!

Bose Device Initial detection is very slow!

ekalipi1ekalipi1 Posts: 19Member

We have incorporated the dialog suggested by Bose into our app to select the Bose product.
However the connection process takes over 2 minutes even when the smartphone and the frames are very close by. 
I am sure that customers will get very annoyed waiting for the frames to connect.
Is this a known issue and is there a fix for it? If not is it something that can be addressed in the next SDK update?

Screen Shot


Comments

  • edited 09/03/2019 - 17:01
    Bryan@Bose[email protected] Posts: 10Moderator
    Hey @ekalipi1
    It shouldn't take 2 minutes. Try updating your firmware using the Bose Updater. 

    Bryan
    Bose
  • ekalipi1ekalipi1 Posts: 19Member
    My firmware is up to date.

    Same result.

    The problem occurs when the phone and frames are turned off and on. The first time the app connects it seems to take forever.  If the frames are shut down and restarted (while the phone is still on) the connection happens quickly. 
    BTW turning off the app and turning it on doesn't affect the connect time.
  • Nadine@Bose[email protected] Posts: 105Moderator
    Hi @ekalipi1 ,

    Is your bose device connected to any other device? Be sure Bluetooth is off for other central devices it could be connected to. Just enable the Bluetooth for the device you want to connect to. Does this still happen?

    Please let me know if this helps?
    nadine
  • ekalipi1ekalipi1 Posts: 19Member
    Yes.

    We are hoping that this issue will be resolved when the new SDK for Android is released.
  • Bryan@Bose[email protected] Posts: 10Moderator
    Hey @ekalipi1  , may I ask what Android Device you are using (model, year, version)? 
  • ekalipi1ekalipi1 Posts: 19Member
    Hi Bryan,

    OnePlus 5
    Android Version 9
    Oxygen Version 9.0.8
    I bought the device in 2017.

    - Kishor Bapat
  • edited 10/02/2019 - 15:59
    Bryan@Bose[email protected] Posts: 10Moderator
    Hey @ekalipi1

    Try lowering the RSSI cutoff value (the default value is -70) when initializing BoseWearable SDK. You can do this by creating a custom configuration in your Application file like so:

    public class App extends Application {
    @Override
    public void onCreate() {
    super.onCreate();

    final Config config = new Config.Builder()
    .rssiCutoff(-80)
    .build();

    BoseWearable.configure(this, config);
    }
    }
    Bryan
    @Bose
  • ekalipi1ekalipi1 Posts: 19Member
    Thanks, will try it this week.
Sign In or Register to comment.