XCode 11 Support

XCode 11 Support

andynovak12andynovak12 Member Posts: 8
I am using XCode 11 Beta and am getting the following error when importing BoseWearable in the example projects from the iOS SDK:
Module compiled with Swift 5.0.1 cannot be imported by the Swift 5.1 compile
I'd love to continue working with SwiftUI in XCode 11 and include the BoseAR frameworks, but at this point I am stuck. Is it possible to share a version of the frameworks that were compiled with Swift 5.1?

Best Answer

Answers

  • Nadine@Bose[email protected] Member Posts: 111
    Hi @andynovak12 ,

    At the moment, we are not compataible with xcode 11 beta.  You'll have to downgrade xcode in order for the SDK to work.

    So sorry about that,
    Nadine
  • andynovak12andynovak12 Member Posts: 8
    Thanks for the quick reply @[email protected] !
    Is there an expected date when Bose will support Xcode 11?
  • Nadine@Bose[email protected] Member Posts: 111

    Hi @andynovak12 ,


    I've actually reached out to our team about this. I think I was mistaken about our SDK not being compatible. Since Xcode 11 is at 5.1, we should be compatible -- our SDK is at 5.0.  Something may be buggy in Xcode 11 for it not to work.  Either way, if development is pressing, it’s probably best to downgrade from Xcode until this version is stable.  


    Best,

    N


  • Michael@Bose[email protected] Member Posts: 66
    One other thing to note @andynovak12 - we can't officially support beta programs for Xcode, so even if it were to work, we recommend building with a recent stable, non-beta version of Xcode for best results, and to avoid issues like this in the future.

    To answer your question directly, though:

    You can expect the Bose AR SDK for iOS to support Xcode 11 once Xcode 11 has a live, stable non-beta version that Apple is recommending all developers use and Bose has pushed a post-Xcode 11 stable non-beta version update to the Bose AR SDK for iOS.

    Hope this helps!

    Michael @ Bose
  • andynovak12andynovak12 Member Posts: 8
    Thanks for the replies @[email protected] and @[email protected] . Unfortunately, precompiled frameworks still have to be used with the same version of Swift that Xcode is running, so I don't think it is possible to use XCode 11 Beta with the Bose frameworks. I am excited to use this new Bose technology alongside the new SwiftUI tools when you do release support for XCode 11!
  • joshkopecekjoshkopecek Member Posts: 1
    @[email protected] @[email protected] @andynovak12
    xcode 11 is now out of beta and I was automatically updated, making my xcode project unbuildable.
    It would be great to get support for this asap.
  • Nadine@Bose[email protected] Member Posts: 111
    Hi @joshkopece,
    I'll check with our teams and get back to you! Thanks!
Sign In or Register to comment.