Unable to view API

Unable to view API

JustAnotherUserJustAnotherUser Posts: 8Member

When navigating to API reference page not found error is presented.

Comments

  • Zach@Bose[email protected] Posts: 156Admin
    Hi there - you've actually caught us right in the middle of an update that's in process, so the documentation is intermittently available at the moment. I'll let you know here once things are all set!
  • Zach@Bose[email protected] Posts: 156Admin

    Hi @JustAnotherUser ,

    Everything is now complete with the update; you should not have any issues viewing the API reference here: https://developer.bose.com/guides/bose-soundtouch-api/bose-soundtouch-api-reference.

    Thanks! Zach

  • bjgeiser1bjgeiser1 Posts: 2Member
    I can no longer find the API documentation that appeared here https://developer.bose.com/soundtouch-control-api-websocket-notifications/apis before your update.
  • Zach@Bose[email protected] Posts: 156Admin

    Hi @bjgeiser1 ,

    All of the documentation has just been consolidated into a single API reference here: https://developer.bose.com/guides/bose-soundtouch-api/bose-soundtouch-api-reference

    And some of the supporting documentation has been broken out into Guides such as this one: https://developer.bose.com/guides/bose-soundtouch-api/working-websockets

    There shouldn't been anything missing, but if you are having trouble finding something specifically, please let me know!

  • bjgeiser1bjgeiser1 Posts: 2Member
    The documentation around websockets feels incomplete. For instance which devices support websockets? I seem to recall the old documentation stating that only the SoundTouch 10, 20 and 30 did. Next, which port is the socket listening for a connection on? Seems to be 8080 but thats also not in the documentation.
  • Zach@Bose[email protected] Posts: 156Admin
    Hi @bjgeiser1 - You're right, it looks like some stuff was accidentally cut out in the transition! I've updated the Working with Websockets guide (https://developer.bose.com/guides/bose-soundtouch-api/working-websockets) to reflect product compatibility and the port (which is indeed 8080).

    Note, websockets are compatible with all products, not just the SoundTouch 10, 20, and 30. The only API feature that does not apply to all products is Audio Notifications (the /speaker endpoint), which only works with SoundTouch 10, SoundTouch 20 Series III, and SoundTouch 30 Series III, which is captured in the reference documentation for /speaker.

    Thanks for the feedback and helping us make these corrections! Let me know if you see anything else.
  • emorissetemorisset Posts: 1Member
    Hi Zach,
    Can we expect the SoundTouch 20 series II to get Norifications in a future firmware ?
    Thanks.
  • Zach@Bose[email protected] Posts: 156Admin
    Hi @emorisset

    Right now, our focus is on building out our new Smart Home API, which we announced in this post. As mentioned in that post, while we will continue to support the existing SoundTouch API feature set, we likely won't be investing in new features for the SoundTouch API. 

    If anything changes we will definitely provide an update, but as of now it is unlikely that any SoundTouch products that don't already have Audio Notifications will receive an update with compatibility.
  • LiangLiang Posts: 1Member
    Hi Zach 
    Is here has offline PDF version of these APIs? sometimes I am not able to login the site from home. Only can check the site when I in the office. 

    Best, 
    Liang



  • Zach@Bose[email protected] Posts: 156Admin
    Hi @Liang

    There is a "Printer Friendly" link at the bottom of the API reference docs that you can use to create a single page that can then be saved as a PDF. It's admittedly not yet a totally optimized view, but hopefully it can work for you!

    That said, I'm sorry you have issues logging into the site from home! Are you running into a specific error on the portal? If so and you're willing to help us troubleshoot, can you direct message me with a screenshot of the error you are seeing? I can follow up from there with some questions that hopefully can lead to either a workaround for you or a fix on our end.

    Finally, here's a screenshot of the printer friendly link: 



  • jasebobjasebob Posts: 1Member
    This worked a week or two ago. But now I access API docs, and the java script to unroll the descriptions unrolls it and immediately rolls it up again before you can read it.
    Worse still the printer friendly link shown above has gone, so it pretty much inaccessible.
    I tried this in Chrome and Edge browsers, same behaviour.




  • kennixkennix Posts: 1Member
    I'm getting the same behavior with all browser (firefox, chrome, IE and Edge) on 2 different computers.
    Is there any pdf file we can download until you fix the issue ?

    thanks !
  • benparkbenpark Posts: 6Member
    Hello same problem for me. Wait for good news
  • Flip747Flip747 Posts: 1Member
    Hi there, I can’t access any more the detailed descriptions for any of the methods - seems the drop down menus are broken. When are you going to fix this? Thanks
  • Zach@Bose[email protected] Posts: 156Admin
    Hi all,

    Sincere apologies for the delay in addressing this thread. I'm no longer able to reproduce the issue with the dropdown menu on chrome and edge and believe it has been resolved -- if anyone is still experiencing that issue can you please post or DM me the browser and version you are using, and what behavior you are seeing?

    Thanks,
    Zach
  • benparkbenpark Posts: 6Member
    Hello
    I can't sign in on Firefox quantum 66.0.2 64 bits.

    Ok on Edge
  • Zach@Bose[email protected] Posts: 156Admin
    Hi @benpark - sounds like you're talking about a login issue rather than an issue with the API documentation itself. On firefox, can you try clearing your cookies and attempting to log in again? Also, please ensure you are not running any extensions that might block third party cookies or restrict javascript, as that can interfere with the sign-in process.
  • benparkbenpark Posts: 6Member
    You' re right .
    Without Ghostery i can sign in.
    Api documentation is enable too
Sign In or Register to comment.