[IMPORTANT] Changes Coming In v4.1 of the Bose AR SDK for Unity (2017.4 Support Ending +TextMeshPro)

[IMPORTANT] Changes Coming In v4.1 of the Bose AR SDK for Unity (2017.4 Support Ending +TextMeshPro)

Michael@Bose[email protected] Member Posts: 66
Hi everyone!

There are two important changes coming to the next SDK release that we would like to give a heads up on.

2017.4 Support Ends
As of the next release, our SDK will no longer support Unity 2017.4.x.

From a version support standpoint, our team has followed Unity’s TECH and LTS support, which is deprecating support for 2017.4 within the next few weeks. As a benefit to this upgrade, we have made changes to the SDK that take advantage of certain features in 2018.x that are no longer backwards compatible with 2017.4, including assembly definition improvements and the package manager.

To continue using any Bose AR projects built in 2017.4, you will need to update your project to 2018.4 or later.

TextMeshPro Dependency
We have now swapped all text rendering in the Connection UI and Sensor Service Suspension UI to TextMeshPro to ensure crisp text rendering for all resolutions.

Your project will need to enable the TextMeshPro package in the PackageManager to avoid compile errors.

Cheers,

[email protected]
Sign In or Register to comment.