Trouble getting Unity demos to work properly

Trouble getting Unity demos to work properly

jpinkl2jpinkl2 Member Posts: 8
Hello, I am new to Unity and have experienced trouble getting the demos working on my Windows laptop. 

I have downloaded the Unity SDK and was able to find the Bose folder in my assets folder in my Unity project. 

However, I am not able to access the demos under Tools > Bose Wearable. "Build Wearable Demo" is greyed out and unclickable here. 

I was able to find (in the "Content Demos" directory) and load up the three demo scenes, but when I run them (after connecting the Bose Frames to my computer) nothing happens. 

When I run the basic demo in this way, I get this error: "NullReferenceException: object reference not set to an instance of an object"

What am I doing wrong? Sorry if this is a very elementary mistake!!

Comments

  • Filip@Bose[email protected] Member Posts: 43
    Hey jpinkl2, did you trying going into build settings and switching platform to either Android or iOS? You have to choose a mobile platform for the Bose AR Unity SDK to work.
  • jpinkl2jpinkl2 Member Posts: 8
    Thanks for the reply. I built an iOS, it looks like it just made C# project files and a visual studio solution file (.sln). Do I now run the project in Visual Studio? Sorry for the dumb question, first time doing this and couldn't immediately get this rolling
  • jpinkl2jpinkl2 Member Posts: 8
    I gave it another shot but within Unity. I first imported the Bose Frames Unity SDK to my project, then I went to build settings, selected the 3 demo scenes as "Scenes in Build", selected iOS, then hit the "Build" button.

    I get a "Copying File Failed" message. "Copying Temp/StagingArea/Trampoline to /Volumes/CENTON USB/Frames May attempt/secondattempt/1: No such file or directory"

    I then did a force quit, reopened and tried to run it from Tools > Bose Wearable > Build Wearable (since I previously opened "build settings", I think this is why this was no longer greyed out for me). I got the same Copying File Failed message with this below "Copying Temp/StagingArea/Data to Temp/StagingArea/Trampoline/Data: No such file or directory". Could you please help me figure out what I am doing wrong?
  • Filip@Bose[email protected] Member Posts: 43
    Hey jpinkl2, I think I have your solution.
    From the SDK guides:
    https://developer.bose.com/guides/bose-ar/sdk-demos

    To build this demo:

    1. Ensure your editor is set to a supported platform.
    2. Select Tools > Bose Wearable > Build Wearable Demo

  • jpinkl2jpinkl2 Member Posts: 8
    Please see my last comment. I followed these instructions but got a "Copying File Failed" message saying "Copying Temp/StagingArea/Data to Temp/StagingArea/Trampoline/Data: No such file or directory". Could you please help me figure out what I am doing wrong?
  • edited 05/09/2019 - 12:38
    daniel@bose[email protected] Member Posts: 41
    @jpinkl2  I'm sorry to see your initial getting started with Unity experience isn't going well.  
    The error message seems to indicate a file copying problem within the Unity build process itself.   Unity creates temp files as part of the build process and the error indicates a failure to copy that data.

    There's many potential reasons why files fail to copy, such as permissions, mis-matched versions of Unity tools, caching of old values.  It can be really challenging to solve.   This may not directly relate to our SDK's plugin.  The unity forums are a good place to start when a problem is related to your Unity toolchain setup.

    I did a brief search and found a few resolutions in this post.
    https://forum.unity.com/threads/error-building-player-ioexception-failed-to-move-file.258111/

    And this post shows the issue and resolution as well.
    https://answers.unity.com/questions/990499/error-building-player-ioexception-failed-to-copy.html

    My suggestion would be to review both posts and try the solution recommended in the second post. 

    A final more general tip would be to make sure you build your project with a stable release, vs the latest from Unity.

    For compatibility with our SDK we currently recommend using Unity: 2017.4 or greater

    Here's the full requirements documentation:
    https://developer.bose.com/guides/bose-ar/getting-started-unity

    Again, I'm sorry this was your first experience with Unity and our SDK.  Please do report back if you find a quick resolution.

    @[email protected]







Sign In or Register to comment.