(solved) Xcode 10.1 (swift 4.2.1) BoseWearble compiles with swift 5.0. Cannot compile any examples.

(solved) Xcode 10.1 (swift 4.2.1) BoseWearble compiles with swift 5.0. Cannot compile any examples.

edited 04/03/2019 - 16:57 in Bose AR SDK for iOS
chrisallickchrisallick Member Posts: 6
I solved the problem by downloading the Swift 5.0 Development Snapshot and specifically, following these instructions (only difference is you'll select workspace vs project):

https://learningswift.brightdigit.com/swift-5-0-xcode-10-1/


error:
"Module compiled with Swift 5.0 cannot be imported by the Swift 4.2.1 compiler"

I tried adjusting the pod version in the Podfile but it wouldn't let me.

Any fixes? I tried to adjust the swift version in xcode, and it wouldn't compile.

Pretty much blocked at this point.

Comments

  • edited 04/16/2019 - 16:20
    daniel@bose[email protected] Member Posts: 41

    Hi chrisallick,

    Apple recently released Xcode 10.2 which now ships the generally available (GA) version of Swift 5.0.

    Our latest version of the Bose AR SDK 3.0.12 (Beta) was updated to include the support for Swift 5.0

    We recommend updating your toolchain to include Xcode 10.2 with Swift 5.0

    [email protected]

This discussion has been closed.