Site login broken

Site login broken

rozzierozzie Member Posts: 1

You might want to fix this before your sxsw launch, because it's fairy serious. 100% repro.
0) I'm using an iPad on latest version of ios. Fails both in normal and "desktop mode.
1) In Safari, go to
2) click Sign In button in upper right
3) result:

Unhandled exception
An unhandled exception was thrown.
If you report this error, please also report this tracking number which makes it possible to locate your session in the logs available to the system administrator:

d1d8317f6fCopy to clipboard
Debug information
The debug information below may be of interest to the administrator / help desk:

0 /srv/bindings/c7b330047b3546aba81255b6a1600088/code/private/simplesamlphp/www/module.php:180 (N/A)
Caused by: sspmod_saml_Error: AuthnFailed: invalid user
3 /srv/bindings/c7b330047b3546aba81255b6a1600088/code/private/simplesamlphp/modules/saml/lib/Message.php:392 (sspmod_saml_Message::getResponseError)
2 /srv/bindings/c7b330047b3546aba81255b6a1600088/code/private/simplesamlphp/modules/saml/lib/Message.php:499 (sspmod_saml_Message::processResponse)
1 /srv/bindings/c7b330047b3546aba81255b6a1600088/code/private/simplesamlphp/modules/saml/www/sp/saml2-acs.php:120 (require)
0 /srv/bindings/c7b330047b3546aba81255b6a1600088/code/private/simplesamlphp/www/module.php:137 (N/A)


  • Zach@Bose[email protected] Admin Posts: 169

    Hi rozzie,

    Apologies that you are seeing this issue. We have seen reports of this intermittently issue and are currently investigating it in detail. We believe it is related to the browser blocking third party cookies, but it's been hard for us to reproduce - using the latest version of iOS on an iPad in Safari here on my end, I just followed your steps and was unable to reproduce. We do think we have a fix in the works to help mitigate the issue, though if all cookies are blocked this issue will likely continue to occur.

    Again, apologies for the inconvenience at this time. I'll post again here once our fix is in place.


  • tbillstroemtbillstroem Member Posts: 1

    Hello there,

    A moment ago, i tried to login to the developer-portal for the first time using my Bose-account, since this was the first time I logged in, I had to create a handle/username for the forum.

    After entering the username I was unable to press submit "Done", I checked the terminal and found this error:

    TypeError: undefined is not an object (evaluating '$.Deferred')
        checkLoginIDAvailability — js_Ibye2AK0vBOHusWenDx-hr7LLzixbBFtqgXBuw5lWa4.js:108
            Global Code

    I checked the imported jQuery-library and noticed that the requested jQuery-function Deferred() was included in the lib. The issue was that the jQuery-library had been imported to the variable jQuery and not $.

    Creating a variable named $ that equals jQuery helped my finish my username-registration, if I hadn't done so I would not be able to signup here.
    let $ = jQuery;

  • edited 09/04/2018 - 10:16
    Zach@Bose[email protected] Admin Posts: 169

    Hi tbillstroem,

    Thanks for identifying this! I just tried to reproduce this issue but was not able to, so it's not immediately apparent where the fix you describe is needed. Would you be willing to work with us directly to help us quickly resolve this? If so, could you reach out to us at [email protected]?


Sign In or Register to comment.